Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

taking Lyris down for the weekend
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 4 months ago. Oct 02, 2018 - 07:37 MDT
Investigating
Lyris is working, perhaps with more bounce messages
Posted 4 months ago. Sep 28, 2018 - 19:27 MDT
This incident affected: Lyris.