Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Degreeworks maintenance
Scheduled for Jul 24, 08:00 - 13:00 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 24, 2020 - 10:38 MDT
Scheduled
We will be undergoing scheduled maintenance at this time.
Posted Jun 24, 2020 - 10:35 MDT
This scheduled maintenance affects: ITS-Maintenance and DegreeWorks/CAPP.