Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Office 365 MFA not working
Incident Report for MSU Denver ITS
Resolved
I was able to authenticate my office 365 account through MFA externally. Microsoft status page is stating it is still restoring services.
Posted Oct 18, 2019 - 15:11 MDT
Update
Microsoft status page is set to "Restoring Services". I will keep the status under monitoring till the services have been fully restored.
Posted Oct 18, 2019 - 13:58 MDT
Update
Microsoft status page show that the issue has been resolved and mitigated. Below is the most recent update from microsoft:
Current status: We've taken multiple actions to mitigate impact and are working to validate service restoration. In parallel, we're continuing to review system logs and service telemetry to better understand the underlying root cause.

I will go ahead and leave this incident report as monitoring for the next hour. If no issue persist i will go ahead and "Resolve" this incident ticket. I will go ahead and close the global ticket seeing that the service is operational.

Thank you,
Waleed E.
Posted Oct 18, 2019 - 12:41 MDT
Update
We are continuing to monitor for any further issues.
Posted Oct 18, 2019 - 12:08 MDT
Monitoring
I have been informed from an employee working from home that he was able to log into his office 365 account using MFA. MFA seems to be working for some of its customers. I will be be keeping my eye on the office 365 status page and will be updating this status page every hour.
Thank you
Posted Oct 18, 2019 - 12:00 MDT
Identified
MFA is back down. Users outside of campus will not be able to login into their office 365 accounts. I will be updating the global ticket.
Posted Oct 18, 2019 - 11:42 MDT
This incident affected: Office 365/Email.