Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Canvas Interruption
Incident Report for MSU Denver ITS
Resolved
Amazon was able to restore connectivity in AWS. Canvas is reporting the issue has been resolved on their end.
Posted Dec 15, 2021 - 10:00 MST
Update
The issue seems to be on Amazon's end. Amazon has identified the root cause to be isolated to AWS US-West-2 and has taken steps to restore connectivity. We will continue to monitor the issue to provide updates.
Posted Dec 15, 2021 - 09:25 MST
Monitoring
At this time, MSU Denver is experiencing an unplanned service interruption impacting Canvas and other MSU Denver Services. Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Dec 15, 2021 - 09:11 MST
This incident affected: Canvas.