Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Many MSU Denver web pages are unavailable - use a private or incognito window.

Incident Report for MSU Denver ITS

Resolved

Our vendor has confirmed that the issue has been resolved.
Posted Oct 27, 2025 - 21:58 MDT

Update

We are continuing to monitor for any further issues.
Posted Oct 27, 2025 - 19:26 MDT

Monitoring

According to our vendor: Our teams have identified the issue and have implemented a fix. Please clear your browser cache and reload your site, and if you are still experiencing any errors, please reach out to our Support team. We will continue to monitor for stability.
Posted Oct 27, 2025 - 18:14 MDT

Investigating

We are currently investigating. In the meantime, you may be able to connect to the pages you need by using a private or incognito Window in your browser.
Posted Oct 27, 2025 - 16:48 MDT
This incident affected: www.msudenver.edu - University Website.