Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Footprints is running slow.
Incident Report for MSU Denver ITS
Resolved
Footprints has been restored to normal operation.
Posted 4 months ago. Apr 26, 2019 - 11:38 MDT
Investigating
Footprints is running slow. The Footprints administrator is investigating the issue.
Posted 4 months ago. Apr 26, 2019 - 11:04 MDT