Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

ITS-Maintenance
Incident Report for MSU Denver ITS
Resolved
The system update and maintenance work was completed as anticipated. All services are fully functional. Thank you for your patience during this disruption.
Posted Mar 23, 2018 - 07:34 MDT
Investigating
ITS scheduled maintenance on 3/22

Information Technology Services (ITS) will perform maintenance on the numerous systems from midnight until 6:00 a.m. on Friday, 3/22. If you have any questions or concerns, please contact the ITS Helpdesk at support.msudenver.edu.
Posted Mar 22, 2018 - 22:30 MDT