Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner PROD, Self Service Banner, AppXtender, and DegreeWorks experiencing performance issues
Incident Report for MSU Denver ITS
Resolved
SSB is up and running. Closing the ticket.
Posted Jul 19, 2021 - 11:30 MDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2021 - 11:15 MDT
Investigating
Technicians have been notified and are investigating. Additional details to follow every hour.
Posted Jul 19, 2021 - 10:47 MDT
This incident affected: Production - Self Service Banner 8 (Employee Self-Svc.), Production - Internet Native Banner (Banner Admin Pages), and Production - Degree Works.