Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

MSU Denver Main page not connecting to some services/Unable to use banner connected services
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 15 days ago. Jun 04, 2018 - 05:20 MDT
Update
We are continuing to investigate this issue.
Posted 15 days ago. Jun 04, 2018 - 00:52 MDT
Investigating
We are currently investigating this issue.
Posted 15 days ago. Jun 04, 2018 - 00:39 MDT
This incident affected: Banner Self-Service.