Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Footprints Login issues
Incident Report for MSU Denver ITS
Resolved
Footprints was undergoing maintenance last night. Services have been restored.
Posted Jun 12, 2020 - 06:31 MDT
Investigating
Footprints is currently experiencing login issues. Awaiting response from the application services team in order to determine the cause of this issue.
Posted Jun 12, 2020 - 03:20 MDT