Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

VoiceThread Intermittent Connectivity
Incident Report for MSU Denver ITS
Resolved
VoiceThread reports that they have resolved the issue causing intermittent connectivity.
Posted Apr 02, 2020 - 14:04 MDT
Investigating
VoiceThread service is experiencing intermittent connectivity issues. They are currently investigating the cause. Updates will be provided when more information is available.
Posted Apr 02, 2020 - 13:15 MDT
This incident affected: ITS-Maintenance.