Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Users not able to reach MSU domain with Century Link ISP
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 11:46 MST
Update
It is a nationwide Century Link outage. If you need to reach MSU Denver Domain go through global protect. If you are having network issues please reach out to Century Link. I will update this page once Century link has implemented a solution. Below are the links to email, canvas, and student hub.

Canvas: https://msudenver.instructure.com/login/saml

Email: https://email.msudenver.edu

Student Hub Menu: https://ssb.msudenver.edu/StudentSelfService
Posted Dec 07, 2021 - 12:27 MST
Monitoring
It is a nationwide Century Link outage. If you need to reach MSU Denver Domain go through global protect. If you are having network issues please reach out to Century Link. I will update this page once Century link has implemented a solution.

Thank you.
Posted Dec 07, 2021 - 11:36 MST
Update
We are still investigating the issue. Since our website hub pages is not reachable here are some links to help you navigate to Canvas, email, and student hub menus.

Canvas: https://msudenver.instructure.com/login/saml

Email: https://email.msudenver.edu

Student Hub Menu: https://ssb.msudenver.edu/StudentSelfService

Thank you.
Posted Dec 07, 2021 - 10:05 MST
Update
We are still investigating the issue. It looks like all .msudenver.edu cannot be accessed through Century Link still. Will update as soon as I hear something.
Posted Dec 07, 2021 - 09:52 MST
Investigating
We are currently investigating this issue.
Posted Dec 07, 2021 - 08:57 MST
Update
We are continuing to monitor for any further issues.
Posted Dec 07, 2021 - 08:56 MST
Monitoring
We are currently investigating why users with Century link as their ISP can't reach the MSU Denver domain. The website is reachable if you are on global protect with that ISP.
Posted Dec 07, 2021 - 08:48 MST
This incident affected: sites.msudenver.edu - Faculty/Staff personal websites.