Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Skype Network Connectivity Issues
Incident Report for MSU Denver ITS
Resolved
Root cause has been identified and VOIP is currently working without issue.
Posted 4 months ago. Feb 12, 2019 - 08:32 MST
Investigating
Sporadic issues with Skype phones losing connection working on resolving issues.
Posted 4 months ago. Feb 11, 2019 - 08:54 MST
This incident affected: Skype for Business.