Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

VPN Connection Issue
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 29, 2019 - 13:13 MDT
Investigating
VPN connections are currently unavailable.
Posted 4 months ago. Apr 29, 2019 - 13:01 MDT
This incident affected: VPN Services.