Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Self Service Banner and Banner Admin Pages Service Interruption
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Aug 16, 2021 - 17:23 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2021 - 16:36 MDT
Investigating
At this time, MSU Denver is experiencing an service degradation impacting Banner Self Service (Student/Faculty Hub Main Menus) and Banner Admin Pages (Internet Native Banner 9).

Users are experiencing either very slow performance or their logins to either system are timing out.

Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Aug 16, 2021 - 15:28 MDT
Monitoring
At this time, MSU Denver is experiencing an service degradation impacting Banner Self Service (Student/Faculty Hub Main Menus) and Banner Admin Pages (Internet Native Banner 9).

Users are experiencing either very slow performance or their logins to either system are timing out.

Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Aug 16, 2021 - 15:27 MDT
This incident affected: Self Service Banner 8 (Faculty Self Service, Employee Self-Service, Finance Self-Service) and Internet Native Banner (Banner Admin Pages) - Production.