Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Email Interruption
Incident Report for MSU Denver ITS
Resolved
Microsoft has resolved issues accessing Office 365 email and the system has been restored to full service. All related systems and applications should be functioning as usual. If you notice any issues with campus systems or applications, please contact the ITS Service Desk at 303-352-7548 or www.msudenver.edu/gethelp. We apologize for the disruption in your daily activities during this unexpected outage.
Posted Apr 21, 2020 - 07:02 MDT
Monitoring
Microsoft technicians have confirmed that the issue was caused by a routine service update which inadvertently contained a code issue that prevented some users from accessing email. The change was reverted and service has returned for a majority of affected users.

Monitoring has confirmed that there is some residual impact to a subset of affected users. Microsoft is determining the best method to mitigate impact and restore service for the remaining users who are unable to access email. We expect this process to take an extended period of time to complete.
Posted Apr 20, 2020 - 21:42 MDT
Identified
At this time, MSU Denver is experiencing an unplanned partial outage of Office 365 email access. Microsoft technicians have identified the cause of the issue and are working to restore access to email for those affected by this outage as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Apr 20, 2020 - 18:53 MDT
This incident affected: Office 365/Email.