Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Enrollment Services phones unavailable
Incident Report for MSU Denver ITS
Resolved
Phone service to Enrollment Services has been restored.
Posted Jul 13, 2018 - 12:42 MDT
Investigating
Enrollment Services numbers, such as Admissions and Financial Aid, are currently unreachable; customer who call in are told the number they dialed is not in service. Technicians are currently investigating the issue.
Posted Jul 13, 2018 - 09:28 MDT
This incident affected: Telecommunications.