Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

ITS Walk-in Services Temporarily Suspended
Incident Report for MSU Denver ITS
Resolved
ITS walk-up locations remain closed while campus offices are closed. For technical assistance, please contact the ITS Helpdesk at 303-352-7548 or submit a request via https://support.msudenver.edu/. The Helpdesk phone line is available 24x7, and the support portal linked above is accessible via VPN.
Posted Apr 03, 2020 - 14:50 MDT
Monitoring
Due to building closures and an emphasis on maintaining sound social distancing practices, ITS is temporarily suspending walk-in services at both campus locations. All clients requiring assistance should contact the ITS Helpdesk at 303-352-7548 or submit a request via https://support.msudenver.edu/. The Helpdesk phone line is available 24x7, and the support portal linked above is accessible via VPN.

In cases where in person support is required, technicians will coordinate with the impacted client on an as-needed basis.
Posted Mar 17, 2020 - 13:44 MDT
This incident affected: ITS-Maintenance.