Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Digital Measures / Enrollment Verifications / Faculty/Staff Directory Service Interruption
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jan 16, 2022 - 09:03 MST
Monitoring
At this time, MSU Denver is experiencing an unplanned service interruption impacting Digital Measures,Student Enrollment Verifications, and the MSU Denver Faculty/Staff Directory.

Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Jan 16, 2022 - 08:44 MST
This incident affected: Watermark FS (formerly Digital Measures).