Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Microsoft Teams Interruption
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jul 29, 2021 - 07:29 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2021 - 23:35 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2021 - 18:01 MDT
Update
At this time, MSU Denver continues to experience an unplanned service degradation impacting Microsoft Teams. Technicians are working to resolve it as quickly as possible. We anticipate status update on this issue in the next 60 minutes.
Posted Jul 28, 2021 - 16:13 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2021 - 11:46 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2021 - 10:12 MDT
Monitoring
At this time, MSU Denver is experiencing an unplanned service degradation impacting Microsoft Teams. Approximately 85% of users' activity feed notifications are intermittently delayed. Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Jul 28, 2021 - 10:12 MDT
This incident affected: Office 365/Email.