Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Digital Measures File Upload process degraded
Incident Report for MSU Denver ITS
Resolved
The issue with Digital Measures file uploading has been resolved.

Please reach out to our ITS Service Desk if you continue to have issues with Digital Measures at 303-352-7548 (option 4).
Posted Apr 15, 2021 - 09:42 MDT
Identified
Digital Measures is currently experiencing a service degradation where files uploaded to digital measures are not being copied to our local storage and available to reviewers. We are in communication with the vendor and awaiting an update on the issue.
Posted Apr 13, 2021 - 18:29 MDT
This incident affected: Digital Measures.