Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Academic Lab Printing
Incident Report for MSU Denver ITS
Resolved
PaperCut Server had high memory usage and was slow responsive. Server have been restarted and service is back online. Confirm with live server logs that users are now able to authenticate to PaperCut for Lab printing.
Posted Nov 28, 2018 - 13:27 MST
Investigating
Campus printing is having issues. Currently investigating
Posted Nov 28, 2018 - 12:54 MST
This incident affected: PaperCut (Student Computer Lab Printing Services).