Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

DegreeWorks Reporting Degraded Performance
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 08:19 MDT
Update
Issue has been resolved with DegreeWorks.
Posted Oct 08, 2020 - 08:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2020 - 10:26 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 07, 2020 - 10:26 MDT
Investigating
The routine maintenance is affecting degree works performance.
Posted Oct 07, 2020 - 09:44 MDT
This incident affected: DegreeWorks/CAPP.