Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Some printers are not currently working do to upgrade.

Incident Report for MSU Denver ITS

Resolved

This incident has been resolved.
Posted Jul 24, 2023 - 11:41 MDT

Monitoring

Fixes have been applied. Printers should be back online.
Posted Jul 24, 2023 - 09:41 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 24, 2023 - 09:30 MDT

Investigating

ITS is applying an emergency fix.
Posted Jul 24, 2023 - 09:24 MDT