Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Helpdesk and Enrollment Services Phone System Service Interruption
Incident Report for MSU Denver ITS
Resolved
The phone system for both Call Center at the ITS Helpdesk and Enrollment Services is back to operational state.
Posted 7 months ago. Oct 31, 2018 - 12:31 MDT
Monitoring
The phone system for both Call Center at the ITS Helpdesk and Enrollment Services is back to operational state. We will continue to monitor into tomorrow's business day.
Posted 7 months ago. Oct 30, 2018 - 16:53 MDT
Update
We are continuing to work on implementing the fix.

Thank you for your patience and understanding during this service interruption, we should have another update by 6 p.m. today.
Posted 7 months ago. Oct 30, 2018 - 15:35 MDT
Update
We are continuing to work on implementing the fix. In the meantime, the service will continue to have limited availability. Please continue to try your call again or at a later time.

Thank you for your patience and understanding during this service interruption, we should have another update by 4 p.m. today.
Posted 7 months ago. Oct 30, 2018 - 13:56 MDT
Identified
The root cause have been identified and we are currently working on implementing the fix. In the meantime, the service will have limited availability. Please continue to try your call again or at a later time.

Thank you for your patience and understanding during this service interruption, we should have another update by 2 p.m. today.
Posted 7 months ago. Oct 30, 2018 - 12:45 MDT
Investigating
We are currently investigating this issue where external numbers are not routing within our ShoreTel phone systems to our Call Centers for ITS Helpdesk and Enrollment Services.
Posted 7 months ago. Oct 30, 2018 - 12:20 MDT