Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

CenturyLink MPLS and Voice Services are Down
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted May 07, 2020 - 09:40 MDT
Update
There are no new updates. Work is still being done; and I will be monitoring the incident. Will update when i have more information.

Thank you
Posted May 06, 2020 - 21:53 MDT
Update
Century Link is still implementing the fix. Final update will be provided after work is done. Will be monitoring the incident.

Thank you
Posted May 06, 2020 - 20:54 MDT
Update
There is no updates for now. Still monitoring the incident.

Thank you
Posted May 06, 2020 - 19:59 MDT
Update
At this time all services are stable and working. We are continuing to monitor the problem till the work needed to resolve this problem is completed.

Thank you
Posted May 06, 2020 - 18:53 MDT
Update
The incident seems to be resolved and operational again. We will still continue to monitor it for another hour since Century Link has not provided with actual resolution.

Thank you
Posted May 06, 2020 - 16:45 MDT
Update
Century Link seems to have resolved the issue. We will be monitoring the incident for another hour or so before changing the status to resolved.

Thank you
Posted May 06, 2020 - 16:07 MDT
Update
There is no update. We are still monitoring the issue. Some calls are working and some are not. Will keep updating as I get more information.

Thank you
Posted May 06, 2020 - 15:15 MDT
Update
The issue is not completely resolved; but is improving. We might see some residual outages, please be patient as we are still monitoring the issue. Will update when I have an update.

Thank you
Posted May 06, 2020 - 14:17 MDT
Monitoring
Services are restored. We will be monitoring.
Thank you
Posted May 06, 2020 - 13:18 MDT
Identified
Century link has identified the issue and are currently onsite working to resolve the issue.

Thank you
Posted May 06, 2020 - 12:50 MDT
Update
CenturyLink is experiencing a major outage in the Denver area. They are working to resolve. Once an update is available I will update the incident.
Posted May 06, 2020 - 12:05 MDT
Investigating
We are currently investigating this issue.
Posted May 06, 2020 - 11:35 MDT
This incident affected: Telecommunications.