Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Network Service Degradation in Administration Building
Incident Report for MSU Denver ITS
Resolved
We have resolved network connectivity issues in the Administration Building and the network has been restored to full service. All systems and applications should be functioning as usual. If you notice any issues with campus systems or applications, please contact the ITS Help Desk at 303-352-7548 or www.msudenver.edu/gethelp. We apologize for the disruption in your daily activities during this unexpected outage.
Posted 18 days ago. Oct 01, 2019 - 08:21 MDT
Investigating
We have received multiple reports of network service degradation in the Administration Building. Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted 18 days ago. Oct 01, 2019 - 08:10 MDT
This incident affected: Campus Network and Wireless Network.