Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Skype For Business Interruption
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 17:24 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 02, 2020 - 16:54 MDT
Identified
At this time, MSU Denver is experiencing an UNPLANNED SERVICE DEGRADATION on Skype for Business. Technicians are aware of the issue and are working to resolve the issue as quickly as possible. We anticipate a status update on this issue in 60 minutes.
Posted Jun 02, 2020 - 15:52 MDT
This incident affected: Skype for Business.