Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

EvalutationKIT Interruption
Incident Report for MSU Denver ITS
Resolved
EvaluationKIT has been restored to full service. All related systems and applications should be functioning as usual. If you notice any issues with campus systems or applications, please contact the ITS Help Desk at 303-352-7548 or www.msudenver.edu/gethelp. We apologize for the disruption in your daily activities during this unexpected outage.
Posted Apr 20, 2020 - 12:42 MDT
Monitoring
EvaluationKIT technicians resolved issues related to accessing the service. We are monitoring EvaluationKIT's availability and are awaiting updates on the system status from the vendor.
Posted Apr 20, 2020 - 11:52 MDT
Investigating
At this time, MSU Denver is experiencing an unplanned outage on EvaluationKIT. Technicians are aware of the issue and are working to resolve the issue as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Apr 20, 2020 - 11:36 MDT
This incident affected: EvaluationKIT (Course Evaluations).