Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Phones are unavailable
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 17:31 MDT
Update
The issue has been identified and resolved. All phones are in working order at this time.
Posted Oct 29, 2020 - 17:28 MDT
Update
We are continuing to investigate the issue. Another update will be provided in an hour.
Posted Oct 29, 2020 - 17:00 MDT
Update
An urgent support request has been opened with our SBC provider to continue work on investigating the issue. Another update will be provided in an hour.
Posted Oct 29, 2020 - 16:08 MDT
Investigating
We are currently investigating this issue. Another update will be provided in an hour.
Posted Oct 29, 2020 - 15:09 MDT
This incident affected: Skype for Business and ShoreTel Call Center Services.