Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Newly admitted student accounts after 12/13/24 do not appear in Navigate and cannot log in.
Incident Report for MSU Denver ITS
Resolved
The incident has been resolved per the vendor.
Posted Dec 23, 2024 - 17:05 MST
Monitoring
A fix has been implemented, and we are monitoring the situation.
Posted Dec 23, 2024 - 11:51 MST
Identified
The issue has been identified and we are working with the vendor to resolve. Newly admitted students after 12/13 are not in Navigate or able to log in
Posted Dec 20, 2024 - 18:39 MST
Investigating
We are currently investigating this issue .It has been reported to Navigate and we are monitoring the situation.
Posted Dec 20, 2024 - 16:26 MST
This incident affected: SSC Navigate (Advising) Student and SSC Navigate Staff.