Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Possible Network Issues
Incident Report for MSU Denver ITS
Resolved
After monitoring this issue throughout the day, we feel confident that the issue has been resolved.
Posted 5 months ago. Apr 03, 2019 - 16:44 MDT
Monitoring
The network utilization readings are much closer to normal right now. We should be seeing little to no service impacts.
Posted 5 months ago. Apr 03, 2019 - 10:52 MDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Apr 03, 2019 - 10:40 MDT
This incident affected: Campus Network.