Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

JAMF and Self Service

Incident Report for MSU Denver ITS

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 11:25 MDT

Update

Services have been restored.
Posted Apr 17, 2025 - 09:28 MDT

Investigating

JAMF is experiencing an internal issue. Until resolved, Self Service for Macs will not be available.
Posted Apr 15, 2025 - 15:45 MDT
This incident affected: JAMF Self Service.