Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Intermittent web email access errors
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Dec 23, 2020 - 07:14 MST
Update
Microsoft has resolved the issue.
Posted Dec 23, 2020 - 07:14 MST
Monitoring
Microsoft has identified an issue that is intermittently preventing some users from accessing Outlook Web Access with the error "500 Repeated Redirect detected". They have restarted known impacted services to resolve the issue, and are monitoring to see if any additional services are being impacted.
Posted Dec 22, 2020 - 17:01 MST
This incident affected: Office 365/Email.