Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

CenturyLink MPLS and Voice Services are Down
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 11:51 MDT
Update
System has been restored and confirmed that services have been back online.
Posted Jul 16, 2020 - 11:00 MDT
Update
We are continue to investigate this issue. Services impacted includes Skype for Business and ShoreTel.
Posted Jul 16, 2020 - 10:12 MDT
Update
All inbound calls, outbound calls, Shoretel and call center have been impacted by this outage. This issue hasnt been resolved. We anticipate a status update on this issue in 60 minutes.
Posted Jul 16, 2020 - 08:57 MDT
Investigating
CenturyLink is currently experiencing a major outage, causing an impact to our service. They are investigating. We will update as they become available.
Posted Jul 16, 2020 - 08:06 MDT
This incident affected: Telecommunications.