Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Voicemail service Interruption
Incident Report for MSU Denver ITS
Resolved
This is an ongoing open issue with Microsoft, but impacted groups at MSU Denver have been given workarounds. Closing this incident for the time being
Posted Mar 17, 2020 - 13:38 MDT
Update
We are continuing to investigate this issue. If you have any questions, please contact the ITS Service Desk at 303-352-7548.
Posted Mar 04, 2020 - 13:06 MST
Update
We are continuing to investigate this issue. If you have any questions, please contact the ITS Service Desk at 303-352-7548.
Posted Mar 04, 2020 - 11:16 MST
Update
We are continuing to investigate this issue. If you have any questions, please contact the ITS Service Desk at 303-352-7548.

We anticipate a status update on this issue in 60 minutes.
Posted Mar 04, 2020 - 07:52 MST
Update
We are continuing to investigate this issue. If you have any questions, please contact the ITS Service Desk at 303-352-7548.
Posted Mar 03, 2020 - 17:50 MST
Investigating
At this time, MSU Denver is experiencing an UNPLANNED system outage on MSU Denver Voicemail System call-in number 303-615-1000.

Technicians are aware of the issue and are working to resolve the issue as quickly as possible. You can access your voicemail messages via email or Skype for Business. If you have any questions, please contact the ITS Service Desk at 303-352-7548.

We anticipate a status update on this issue in 60 minutes.
Posted Mar 03, 2020 - 16:43 MST
This incident affected: Office 365/Email.