Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Issues with Workday Homepage and Search for Some Production Tenants
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 17:32 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2024 - 16:58 MDT
Investigating
We are currently investigating this issue.
Posted Jun 05, 2024 - 16:54 MDT
This incident affected: Production - Self Service Banner 8 (Employee Self-Svc.).