Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner Self Service Interruption
Incident Report for MSU Denver ITS
Resolved
Multiple contributing factors resulted in issues with Banner Self Service SSO. We have resolved each of the issues and the system has been restored to full service. All related systems and applications should be functioning as usual. If you still notice any issues accessing or utilizing campus systems or applications, please contact the ITS Service Desk at 303-352-7548 or visit msudenver.edu/gethelp. We apologize for the disruption in your daily activities during this unexpected outage.
Posted Feb 23, 2021 - 12:59 MST
Update
Technicians continue to troubleshoot the SSO login issue. However, Self-Service Banner pages and services are still available.
Posted Feb 23, 2021 - 12:23 MST
Update
The issue is related to SSO. However, Self-Service Banner pages and services are still available.
Posted Feb 23, 2021 - 10:53 MST
Update
Technicians are continuing research into the cause of the error. Updates will continue as more information becomes available.
Posted Feb 23, 2021 - 10:37 MST
Update
We are continuing to investigate this issue.
Posted Feb 23, 2021 - 09:13 MST
Investigating
At this time, MSU Denver is experiencing a unplanned service degradation impacting Banner Self-Service. Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 90 minutes.
Posted Feb 23, 2021 - 08:54 MST
This incident affected: Production - Self Service Banner 8 (Employee Self-Svc.).