Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

O365 Web Login Page
Incident Report for MSU Denver ITS
Resolved
Per Microsoft: Preliminary root cause: Engineers determine that a CDN endpoint that is responsible for processing authentication requests became unreachable.
Posted 12 months ago. Oct 11, 2018 - 14:42 MDT
Investigating
Sporadic: sign in page fails to load.
Posted 12 months ago. Oct 11, 2018 - 11:21 MDT
This incident affected: Office 365/Email.