Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Blackboard Learn is Currently Unavailable
Incident Report for MSU Denver ITS
Resolved
Blackboard Learn service is now restored following a DNS outage at Blackboard's hosting site. We will continue monitoring Blackboard Learn for any further interruptions.
Posted 12 days ago. Oct 07, 2019 - 16:47 MDT
Update
We are continuing to work on a fix for this issue.
Posted 12 days ago. Oct 07, 2019 - 16:43 MDT
Identified
Blackboard Learn remains Unavailable at this time . We have contacted Blackboard and are working to resolve the issue. Status will continue to be updated.
Posted 12 days ago. Oct 07, 2019 - 15:40 MDT
This incident affected: Blackboard Learn.