Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

COVID-19 Nationwide Service Degradations
Incident Report for MSU Denver ITS
Resolved
Some services may fluctuate for the duration of this situation. Please continue to limit high-bandwidth application use if you notice service degradations.
Posted Apr 03, 2020 - 14:49 MDT
Investigating
Due to the increased demand of digital services nationwide many online host providers are experiencing intermittent service degradations. ITS recommends limiting your use of high bandwidth activities when you encounter such degradations, such as, turning off your camera and limiting your call to audio when the video connection is poor.
Posted Mar 19, 2020 - 13:10 MDT
This incident affected: ITS Scheduled Maintenance.