Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner 9 Jobsub printing issue
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Nov 28, 2018 - 12:03 MST
Investigating
We are experiencing Jobsub printing issues with some Banner 9 Admin Pages (Forms). We are working with Ellucian to resolve this.
Posted Nov 28, 2018 - 07:54 MST
This incident affected: Production - Internet Native Banner (Banner Admin Pages).