Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

MSUDenver.edu website is down
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Sep 29, 2021 - 17:59 MDT
Investigating
There was a major outage reported to our vendor resulting in MSUDenver.edu briefly going offline. We are currently monitoring the issue.
Posted Sep 29, 2021 - 17:29 MDT
This incident affected: WordPress (sites.msudenver.edu).