Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

AWS Service Degradation may be impacting external applications such as Adobe

Incident Report for MSU Denver ITS

Resolved

AWS has reported that performance issues have been resolved.
Posted Oct 21, 2025 - 12:34 MDT

Identified

Amazon Web Services (AWS) is reporting some degradation of services which don't have a direct impact on MSU Denver Applications, but may result in some issues.
https://health.aws.amazon.com/health/status

Of note are Adobe applications
https://status.adobe.com/

and Canvas (though we have received to reports from MSU Denver of Canvas Issues)
https://status.instructure.com/

Please do not hesitate to report issues with these or other services so that we can share awareness. At this time, MSU Denver can only observe and report on the restoration of services.
Posted Oct 20, 2025 - 10:52 MDT
This incident affected: Telecommunications.