Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Wired network unreliable in Plaza building and Wi-FI unreliable across campus

Incident Report for MSU Denver ITS

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 14:43 MST

Investigating

We are currently investigating and triaging the issues
Posted Feb 13, 2025 - 14:39 MST
This incident affected: Campus Network.