Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

TeamDynamix Failing to Process Email Responses

Incident Report for MSU Denver ITS

Resolved

The issue has been identified and resolved. Email responses to ITS are processing correctly now. Financial Aid and Workday TeamDynamix responses were not effected during this outage.
Posted Mar 21, 2024 - 14:23 MDT

Investigating

TeamDynamix is not processing email responses from users. Replies via email to open tickets are not being seen by technicians on the TeamDynamix ticketing portal. We are currently investigating this issue.
Posted Mar 21, 2024 - 13:41 MDT