Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Covid Grant Form Not Working
Incident Report for MSU Denver ITS
Resolved
The correct link has been communicated as of this time. Closing the incident.
Posted May 05, 2020 - 23:26 MDT
Investigating
There are reports that the Covid Grant form is not working. We are investigating the issue. At this time, it appears that the link may not be correct. Using the following URL instead appears to work. Links on the website and in communication will be updated as soon as possible. This may not be until tomorrow morning. For the time being, please use https://prod-banner.msudenver.edu/pls/prod_web/rwwcovd.P_RequestLogin as the URL for this form instead of using a link. Note that this isn't a guaranteed fix, but appears to work at least for some.
Posted May 05, 2020 - 18:40 MDT
This incident affected: Production - Self Service Banner 8 (Employee Self-Svc.).