Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Liquid Files Login Portal is Currently Unavailable
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 08:32 MDT
Investigating
We are currently investigating this issue.
Posted Sep 10, 2021 - 07:52 MDT
This incident affected: Information Security.