Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

TeamDynamix service management (ticketing) system degredation

Incident Report for MSU Denver ITS

Resolved

TeamDynamix rolled back the 12.0 version release which restored functionality to the affected ticketing environment by mid-day on 6/2.

We will learn more from the vendor on root cause of this incident and plans to reschedule the 12.0 release with us.
Posted Jun 03, 2025 - 08:54 MDT

Monitoring

TeamDynamix (TDX) experienced performance issues today following the release of some important new capabilities over the weekend.

Due to a technical concern, TDX has decided to roll back the new version of the service for the US-based customers who received it this weekend. *This rollback only impacts the group of US-based customers that went live on the new UX in this specific wave.*
TDX successfully rolled out the new UX to 30% of customers prior to this weekend, and these performance issues were not previously seen.
----
MSU Denver IT Services will monitor the success of the rollback with all ticketing/platform users across the institution to ensure everyone can resume their normal support work.
Posted Jun 02, 2025 - 11:28 MDT

Update

TeamDynamix reports they are nearing a fix for the issue that has caused this degradation with the Work Management side of their platform. We'll provide updates as soon as possible.

For immediate/urge support on IT technical support or Workday support, please contact your department of support directly (IT, HR, Office of the Controller) instead of placing a ticket at this time. IT Service Desk: 303-352-5748

Thank you for your continued patience as investigation continues.
Posted Jun 02, 2025 - 09:09 MDT

Identified

The technician side of the TeamDynamix ticketing system is experiencing an outage on the vendor side. Users can still access support portals (support.msudenver.edu) to place tickets, but support staff cannot access the part of the platform where the tickets are received and worked on.

For immediate/urge support on IT technical support or Workday support, please contact your department of support directly (IT, HR, Office of the Controller) instead of placing a ticket at this time.

We will post updates as we receive them from TeamDynamix

IT Service Desk: 303-352-5748
Posted Jun 02, 2025 - 08:20 MDT
This incident affected: ITS Scheduled Maintenance.