Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Some phone extensions unable to leave voicemail messages
Incident Report for MSU Denver ITS
Resolved
We believe this issue has been resolved at this time. If you continue to experience issues please reach out to our helpdesk at 303-352-7548.
Posted Sep 26, 2024 - 06:48 MDT
Identified
We believe the issue has been identified at this time. Updates have been run but it will take time to see the changes applied. Further updates will be provided in the morning once additional troubleshooting can occur.
Posted Sep 25, 2024 - 20:25 MDT
Investigating
We are currently investigating a reported issue with a number of on campus phone extensions being unable to leave voicemail messages. Our Telecommunications team is in the process of identifying and resolving the issue.
Posted Sep 25, 2024 - 16:59 MDT
This incident affected: Telecommunications.